Wos3 "Failed to initialise the engine"

Welcome to the new TML-Studios Community! Please read through the Community Rules and Guidelines and Tips & Tricks. Have fun!
  • I have been advised to post here by Aerosoft who are out of ideas. World of Subways 3 worked fine until a year ago, then an "activation required" message appeared. I recently found out that the reason it failed was due to an update to Aerosoft Launcher. I installed the update and WoS3 worked again. As I had now got a new (larger) monitor, I changed the resolution in Settings. The program offered me something like 1600 x 1200, I assumed it had queried the monitor and accepted. Since then, when trying to run the program, I get a black screen and the message that it has "Failed to initialise the engine". I have now confirmed that my monitor is actually 1920 x 1080 and am assuming that the wrong resolution entered is causing the problem. I have tried uninstalling (using both Windows and IOBit uninstallers) and then reinstalling but this makes no difference. I suspect that the resolution is stored in a config file that does not get deleted during an uninstall. Can anyone help me to get the program up and running again please? I should add that no changes have been made to the PC and it ran fine on it for the last five or six years.

  • Hello all,

    Dond´t know if you can help me, but just bought this sim on Steam and when launching it runs on my secondary monitor (I have two screens). Is there a way to setup the sim so that it runs on my main monitor?